35 lines
842 B
Bash
35 lines
842 B
Bash
# Maintainer: Martin Brodbeck <martin at brodbeck-online dot de>
|
|
pkgname=kima2
|
|
pkgver=1.7.1
|
|
pkgrel=1
|
|
pkgdesc="A small cash point program for children's things markets (German only)"
|
|
arch=('i686' 'x86_64')
|
|
url="http://www.rustysoft.de/software/kima2"
|
|
license=('custom')
|
|
depends=('glibc' 'libusb' 'qt6-base' 'sqlite3')
|
|
makedepends=('boost>=1.62')
|
|
source=(git+https://git.rustysoft.de/martin/kima2)
|
|
sha256sums=('SKIP')
|
|
|
|
build() {
|
|
cd $pkgname
|
|
|
|
git checkout v$pkgver
|
|
git submodule init
|
|
git submodule update
|
|
|
|
if [ -d build ]; then
|
|
rm -rf build
|
|
fi
|
|
mkdir build && cd build
|
|
|
|
cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DKIMA2_USE_EXTERNAL_JSON=OFF ..
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd $pkgname/build
|
|
make DESTDIR="$pkgdir" install
|
|
cd ..
|
|
install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
|
|
}
|